LACP and LLDP protocols doesn't work

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Post Reply
mvsilva
Posts: 2
Joined: Fri Sep 20, 2019 9:09 pm

LACP and LLDP protocols doesn't work

Post by mvsilva » Fri Sep 20, 2019 9:36 pm

Hi guys!


I trying activate an etherchannel with LACP, but it doesn't work.

The local switch inform that the remote switch isn't running LACP.

How can i fix this error?

I suspect there is an issue with my vm. I using google cloud to work on eve-ng.

I have problems with LLDP protocol too.
I activate the protocol, but the switches can't learn any neighbor.

Note:

The PAgP and CDP protocols still running with no problem.

Can someone help-me with this issue?

The outputs bellow are the same in both switches:


SW03

interface Port-channel1
!
interface GigabitEthernet0/0
description LINK-SW04
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/1
description LINK-SW04
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-protocol lacp
channel-group 1 mode active

SW04

interface Port-channel1
!
interface GigabitEthernet0/0
description LINK-SW03
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-protocol lacp
channel-group 1 mode active
!
interface GigabitEthernet0/1
description LINK-SW03
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-protocol lacp
channel-group 1 mode active


ERROR MESSAGE:

*Sep 20 21:26:26.290: %EC-5-L3DONTBNDL2: Gi0/1 suspended: LACP currently not enabled on the remote port.
*Sep 20 21:26:26.357: %EC-5-L3DONTBNDL2: Gi0/0 suspended: LACP currently not enabled on the remote p


SW04#show etherchannel detail
Port: Gi0/0
------------

Port state = Up Cnt-bndl-rmt Suspend Mstr Rmt-LACP_Dsbl Not-in-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Port: Gi0/1
------------

Port state = Up Cnt-bndl-rmt Suspend Mstr Rmt-LACP_Dsbl Not-in-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Port-channel: Po1 (Primary Aggregator)

------------

Age of the Port-channel = 0d:00h:26m:55s
Logical slot/port = 16/0 Number of ports = 0
HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = LACP
Port security = Disabled

SW04#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Gi0/0(s) Gi0/1(s)


I can see the LLDP commands (lldp transmit/receive) on interface doesn't apply on the interface.

SW04#show lldp neighbors
Capability codes:
(R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
(W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other

Device ID Local Intf Hold-time Capability Port ID

Total entries displayed: 0

SW04#show lldp interface
GigabitEthernet0/1:
Tx: enabled
Rx: enabled
Tx state: IDLE
Rx state: WAIT FOR FRAME

SW04#show lldp traffic
LLDP traffic statistics:
Total frames out: 450
Total entries aged: 0
Total frames in: 0
Total frames received in error: 0
Total frames discarded: 0
Total TLVs discarded: 0
Total TLVs unrecognized: 0

Uldis (UD)
Posts: 2505
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: LACP and LLDP protocols doesn't work

Post by Uldis (UD) » Sat Sep 21, 2019 3:23 pm

All works !

first you have wrong int po1 configuration, you have missed on it same cfg what is Ge interface:
You missed cfg on Po1 !!!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk


Ports in LACP are:
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet1/3
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
channel-group 1 mode active

SW2#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-------------------------------------------
----
1 Po1(SU) LACP Gi1/2(P) Gi1/3(P)

LLDP as well is working vIOS to vEOS arista switch see pic below :)

version of vIOS

SW1#sh ver
Cisco IOS Software, vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Version 15.2(CML
_NIGHTLY_20180510)FLO_DSGS7, EARLY DEPLOYMENT DEVELOPMENT BUILD, synced to V152_6
_0_81_E
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Thu 10-May-18 05:13 by mmen


Uldis
You do not have the required permissions to view the files attached to this post.

mvsilva
Posts: 2
Joined: Fri Sep 20, 2019 9:09 pm

Re: LACP and LLDP protocols doesn't work

Post by mvsilva » Sat Sep 21, 2019 11:32 pm

Hello!

I enjoy your answer, but can see there is a issue with my IOL image, see my configuration attached.

Currently i use this IOL version:

SWDT02#show version
Cisco IOS Software, Linux Software (I86BI_LINUXL2-ADVENTERPRISEK9-M), Version 15.2(CML_NIGHTLY_20151103)FLO_DSGS7, EARLY DEPLOYMENT DEVELOPMENT BUILD, synced to FLO_DSGS7_POSTCOLLAPSE_TEAM_TRACK_DSGS_PI5
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Wed 04-Nov-15 02:31 by mmen

And, i use this vIOS version:

Switch#show version
Cisco IOS Software, vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Version 15.2(4.0.55)E, TEST ENGINEERING ESTG_WEEKLY BUILD, synced to END_OF_FLO_ISP
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Tue 28-Jul-15 18:52 by sasyamal

On both, i have the same problem.

Could you send me an copy of your vIOS image?
You do not have the required permissions to view the files attached to this post.

Uldis (UD)
Posts: 2505
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: LACP and LLDP protocols doesn't work

Post by Uldis (UD) » Sun Sep 22, 2019 7:19 am

it is obviously images issues.
Iam using vIOS
viosl2-adventerpriseK9-M_152_May_2018

SW1#sh ver
Cisco IOS Software, vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Version 15.2(CML_NIGHTLY_20
180510)FLO_DSGS7, EARLY DEPLOYMENT DEVELOPMENT BUILD, synced to V152_6_0_81_E
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Thu 10-May-18 05:13 by mmen

and IOL
i86bi_LinuxL2-AdvEnterpriseK9-M_152_May_2018.bin

SW_IOL#sh ver
Cisco IOS Software, Linux Software (I86BI_LINUXL2-ADVENTERPRISEK9-M), Version 15.2(CML_NIGHTLY_20
180510)FLO_DSGS7, EARLY DEPLOYMENT DEVELOPMENT BUILD, synced to V152_6_0_81_E
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Thu 10-May-18 02:45 by mmen

LACP works between vIOS and IOL Switches.
Both supports LACP and lldp

SAD to say but vIOS has 10 times worse performance than IOL. My favorite are IOL images as switches.

Distribute or share Vendor images in this forum is forbidden. It is illegal to share other vendors proprietary.
Check google.
You do not have the required permissions to view the files attached to this post.

Post Reply