upgrade to Pro - upgrade existing community ed

Moderator: mike

Post Reply
levian71
Posts: 2
Joined: Sun Nov 19, 2017 3:25 pm

upgrade to Pro - upgrade existing community ed

Post by levian71 » Sat Aug 24, 2019 8:43 am

Hi,
i decided to upgrade to the pro version. As i understood the first step is to upgrade my existing version to the latest.
Here is what i did:

1) Created a full clone of my live machine.
2) tried to update/upgrade as per procedure:
https://www.eve-ng.net/community/community-2

root@eve-ng:~# apt autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
linux-image-virtual : Depends: linux-image-4.4.0-159-generic but it is not installed or
linux-image-unsigned-4.4.0-159-generic but it is not installed
systemd : Depends: libsystemd0 (= 229-4ubuntu21.1) but 229-4ubuntu21.6 is installed
Recommends: libpam-systemd but it is not installed
E: Unmet dependencies. Try using -f.
root@eve-ng:~#


root@eve-ng:~# df -h --total
Filesystem Size Used Avail Use% Mounted on
udev 12G 0 12G 0% /dev
tmpfs 2.4G 18M 2.4G 1% /run
/dev/mapper/eve--ng--vg-root 63G 43G 17G 72% /
tmpfs 12G 0 12G 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 12G 0 12G 0% /sys/fs/cgroup
/dev/sda1 472M 471M 0 100% /boot
total 101G 44G 55G 45% -


root@eve-ng:~# apt update
Hit:1 http://www.eve-ng.net/repo xenial InRelease
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Fetched 218 kB in 0s (306 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
298 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@eve-ng:~#
root@eve-ng:~#
root@eve-ng:~# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
linux-image-virtual : Depends: linux-image-4.4.0-159-generic but it is not installed or
linux-image-unsigned-4.4.0-159-generic but it is not installed
systemd : Depends: libsystemd0 (= 229-4ubuntu21.1) but 229-4ubuntu21.6 is installed
Recommends: libpam-systemd but it is not installed
E: Unmet dependencies. Try using -f.
root@eve-ng:~#



when i try a forced upgrade i receive error that no space is left.
gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.9.40-eve-ng-ukms-2+ with 1.
dpkg: error processing package initramfs-tools (--unpack):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@eve-ng:~#



i found following:
https://askubuntu.com/questions/389144/ ... eneric-etc


root@eve-ng:~# find /boot -type f -regex "^.*-generic"
/boot/vmlinuz-4.4.0-104-generic
/boot/abi-4.4.0-134-generic
/boot/initrd.img-4.4.0-101-generic
/boot/System.map-4.4.0-101-generic
/boot/retpoline-4.4.0-121-generic
/boot/System.map-4.4.0-137-generic
/boot/retpoline-4.4.0-116-generic
/boot/abi-4.4.0-127-generic
/boot/retpoline-4.4.0-130-generic
/boot/vmlinuz-4.4.0-101-generic
/boot/abi-4.4.0-87-generic
/boot/initrd.img-4.4.0-130-generic
/boot/config-4.4.0-104-generic
/boot/config-4.4.0-87-generic
/boot/vmlinuz-4.4.0-127-generic
/boot/abi-4.4.0-104-generic
/boot/abi-4.4.0-119-generic
/boot/vmlinuz-4.4.0-134-generic
/boot/abi-4.4.0-116-generic
/boot/config-4.4.0-137-generic
/boot/initrd.img-4.4.0-133-generic
/boot/System.map-4.4.0-121-generic
/boot/retpoline-4.4.0-134-generic
/boot/abi-4.4.0-97-generic
/boot/abi-4.4.0-130-generic
/boot/config-4.4.0-127-generic
/boot/config-4.4.0-112-generic
/boot/initrd.img-4.4.0-116-generic
/boot/System.map-4.4.0-112-generic
/boot/retpoline-4.4.0-137-generic
/boot/config-4.4.0-101-generic
/boot/initrd.img-4.4.0-104-generic
/boot/retpoline-4.4.0-127-generic
/boot/System.map-4.4.0-116-generic
/boot/config-4.4.0-116-generic
/boot/System.map-4.4.0-97-generic
/boot/System.map-4.4.0-130-generic
/boot/System.map-4.4.0-133-generic
/boot/abi-4.4.0-133-generic
/boot/config-4.4.0-119-generic
/boot/vmlinuz-4.4.0-130-generic
/boot/abi-4.4.0-112-generic
/boot/initrd.img-4.4.0-97-generic
/boot/vmlinuz-4.4.0-97-generic
/boot/vmlinuz-4.4.0-87-generic
/boot/config-4.4.0-109-generic
/boot/config-4.4.0-159-generic
/boot/System.map-4.4.0-109-generic
/boot/System.map-4.4.0-87-generic
/boot/config-4.4.0-133-generic
/boot/vmlinuz-4.4.0-109-generic
/boot/initrd.img-4.4.0-112-generic
/boot/initrd.img-4.4.0-109-generic
/boot/config-4.4.0-130-generic
/boot/initrd.img-4.4.0-127-generic
/boot/initrd.img-4.4.0-119-generic
/boot/vmlinuz-4.4.0-112-generic
/boot/initrd.img-4.4.0-87-generic
/boot/vmlinuz-4.4.0-137-generic
/boot/abi-4.4.0-109-generic
/boot/abi-4.4.0-137-generic
/boot/vmlinuz-4.4.0-119-generic
/boot/System.map-4.4.0-119-generic
/boot/retpoline-4.4.0-119-generic
/boot/abi-4.4.0-121-generic
/boot/initrd.img-4.4.0-134-generic
/boot/retpoline-4.4.0-133-generic
/boot/config-4.4.0-97-generic
/boot/System.map-4.4.0-134-generic
/boot/abi-4.4.0-101-generic
/boot/System.map-4.4.0-104-generic
/boot/System.map-4.4.0-159-generic
/boot/initrd.img-4.4.0-121-generic
/boot/vmlinuz-4.4.0-121-generic
/boot/config-4.4.0-134-generic
/boot/config-4.4.0-121-generic
/boot/System.map-4.4.0-127-generic
/boot/vmlinuz-4.4.0-116-generic
/boot/vmlinuz-4.4.0-133-generic


i manually deleted all entries excecpt those:

/boot/System.map-4.4.0-137-generic
/boot/config-4.4.0-137-generic
/boot/retpoline-4.4.0-137-generic
/boot/vmlinuz-4.4.0-137-generic
/boot/abi-4.4.0-137-generic


After reboot i checked my space and it looked much better:

root@eve-ng:~# df -h
Filesystem Size Used Avail Use% Mounted on
udev 12G 0 12G 0% /dev
tmpfs 2.4G 18M 2.4G 1% /run
/dev/mapper/eve--ng--vg-root 63G 41G 20G 68% /
tmpfs 12G 0 12G 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 12G 0 12G 0% /sys/fs/cgroup
/dev/sda1 472M 78M 370M 18% /boot
root@eve-ng:~#

i repeated the upgrade and this time it seemed worked. However i still seem to have the old version installed.

root@eve-ng:~# dpkg -l eve-ng
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii eve-ng 2.0.3-84 amd64 A new generation software for net
root@eve-ng:~#


root@eve-ng:~# apt-get update
Hit:1 http://www.eve-ng.net/repo xenial InRelease
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Fetched 218 kB in 0s (315 kB/s)
Reading package lists... Done
root@eve-ng:~#
root@eve-ng:~#
root@eve-ng:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
eve-ng eve-ng-qemu libdrm-amdgpu1 libdrm2 libgl1-mesa-dri open-vm-tools
ubuntu-minimal unattended-upgrades
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
root@eve-ng:~#


root@eve-ng:~# find /boot -type f -regex "^.*-generic"
/boot/vmlinuz-4.4.0-159-generic
/boot/initrd.img-4.4.0-159-generic



I would like to avoid to install a brand new Pro version, because that would mean that i need to install/create all my images, labs,etc.
I really like to upgrade from my existing Community Edition to the Pro.

Does someone have an idea ?

Thanks,
Oliver

Uldis (UD)
Posts: 2504
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: upgrade to Pro - upgrade existing community ed

Post by Uldis (UD) » Sun Aug 25, 2019 6:30 am

i can help you but come in eve live chat
my chat name is EVE-BG-UD
https://www.eve-ng.net/live-helpdesk
use your gmail account or create new to join in chat

Uldis

Post Reply