High CPU usage - csr1000v-Everest

Moderator: mike

Post Reply
Lango
Posts: 3
Joined: Sun Jun 04, 2017 11:38 am

High CPU usage - csr1000v-Everest

Post by Lango » Sun Jun 04, 2017 11:59 am

Hi Team,

I am new to using eve-ng and i am trying to setup a lab to learn for Cisco certification.

I have added csr1000v-Everest ( 9.16.05.01b) and am able to boot the image with UKSM disabled and CPU Limit enabled.
When i booted 6 instances of csr1000v one by one(with each instance boot completely), the cpu hogs to 80% while the memory is around 47%.
The instances are not inter connected. They are just added and running without any set internetwork.

My M/c Specification is given below

Host OS: Linux Mint
Virtualization tool: virt-manager
Physical Ram: 64GB
CPU: Xeon E5-1620 ( 8 core )
Motherboard: Gigabyte Phoenix SLI with Intel-VT enabled
Eve (Guest OS) : Ubuntu 16.04 LTS
RAM allocated to eve VM : 45 GB
CPU allocated to eve VM : 4

Is there a way to bring down the CPU usage to less than 50%,..I would like to run INE topology for CCIE R&S with 10 instance of csr1000v and a l2IOSv for my study.

Any help would be much appreciated
Thanks
Lango
Screenshot from 2017-06-04 17-26-19.png
You do not have the required permissions to view the files attached to this post.

ecze
Posts: 493
Joined: Wed Mar 15, 2017 1:54 pm

Re: High CPU usage - csr1000v-Everest

Post by ecze » Sun Jun 04, 2017 8:11 pm

Sadly, running eve into qemu/kvm does not offer good performance.

Better to use vmplayer than libvirt to run eve

E.

Lango
Posts: 3
Joined: Sun Jun 04, 2017 11:38 am

Re: High CPU usage - csr1000v-Everest

Post by Lango » Mon Jun 12, 2017 6:52 am

Hi Team,

Managed to run eve in VMworkstation Player.
Could see some +ve results

vIOS are running with CPU usage at 48% and 18% memory (10 vIOS nodes and IOSvl2 node )...which is good for labbing with INE topology.

But no luck while running csr1000v. 6 Nodes of csr1000v causes 80% CPU usage, even when UKSM is disabled and CPU Limit status in "on" state.

Dynamips with c7200 ios with version 15.3.x.x runs quite well.

Not sure if anyone could offer a solution to bring down the CPU usage while running multiple instances of csr1000v ( I used Denali for test )

Any further suggestion or help would be appreciated much.

Uldis (UD)
Posts: 2656
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: High CPU usage - csr1000v-Everest

Post by Uldis (UD) » Mon Jun 12, 2017 8:33 am

CSR NG everest is most heavy CSR image, and such CPU spike simply will be. There is no workarround for this.
Even on Bare esxi everest eat a lot CPU
Most calm for CPU is CSR 3.17

Lango
Posts: 3
Joined: Sun Jun 04, 2017 11:38 am

Re: High CPU usage - csr1000v-Everest

Post by Lango » Fri Jun 23, 2017 6:10 pm

Uldis (UD) wrote:
Mon Jun 12, 2017 8:33 am
CSR NG everest is most heavy CSR image, and such CPU spike simply will be. There is no workarround for this.
Even on Bare esxi everest eat a lot CPU
Most calm for CPU is CSR 3.17
Hi Uldis,

Thanks a lot for the wisely suggestion.
Indeed, 3.17 is calm from CPU perspective and i could boot 10 instance of CSRv nodes with less than 40% CPU (with UKSM disabled ) and around 66% of RAM (45 GB for the Guest VM), which is good for labbing purpose.

Appreciating your suggestion very much and Thanks again
Lango
Screenshot from 2017-06-23 23-35-31.png
You do not have the required permissions to view the files attached to this post.

Post Reply