eve-ng management IPv6 disabled

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

ecze
Posts: 521
Joined: Wed Mar 15, 2017 1:54 pm

Re: eve-ng management IPv6 disabled

Post by ecze » Wed Dec 04, 2019 5:14 pm

We will not enable ipv6 by default.
Next release will permit on gui ( system settings ) to enable ipv6.

Regards,

E.

PS: Currently, you are the only one to complain about ipv6 and we had a lot of complain from users having issue because of ipv6 not working. But we want to be fair. So you will have a gui checkbox to facilitate ipv6 activation.

ongolaBoy
Posts: 8
Joined: Wed Dec 04, 2019 12:17 pm

Re: eve-ng management IPv6 disabled

Post by ongolaBoy » Thu Dec 05, 2019 4:46 am

ecze wrote:
Wed Dec 04, 2019 5:14 pm
We will not enable ipv6 by default.
Next release will permit on gui ( system settings ) to enable ipv6.

Regards,

E.

PS: Currently, you are the only one to complain about ipv6 and we had a lot of complain from users having issue because of ipv6 not working. But we want to be fair. So you will have a gui checkbox to facilitate ipv6 activation.
Thank you.

abdel
Posts: 4
Joined: Thu May 18, 2017 5:48 pm

Re: eve-ng management IPv6 disabled

Post by abdel » Thu Jan 16, 2020 8:59 pm

ON EV-NG server edit /etc/gai.conf and look for #precedence ::ffff:0:0/96 100 and then remove # to uncomment it. RESULT: you don't disable IPv6 and apt-get update will work ipo hanging/timing out on IPv6 servers.
Hope it helps a little

Tomstes
Posts: 3
Joined: Tue Mar 24, 2020 5:09 am

Re: eve-ng management IPv6 disabled

Post by Tomstes » Tue Mar 24, 2020 5:13 am

adsfadsfadsfdwf wrote:
Mon Nov 04, 2019 5:11 am
eve-ng-pro 2.0.6-8, Ubuntu 16.04.6 LTS, 4.20.17-eve-ng-ukms+ running on ESXi

Why is IPv6 keeps getting disabled on every reboot? I need IPv6 for VM management. I

Code: Select all

root@eve:~# sysctl -a | grep net.ipv6 | grep disable_ipv6
sysctl: reading key "net.ipv6.conf.all.stable_secret"
sysctl: reading key "net.ipv6.conf.default.stable_secret"
sysctl: reading key "net.ipv6.conf.docker0.stable_secret"
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.eth0.stable_secret"
sysctl: reading key "net.ipv6.conf.eth1.stable_secret"
net.ipv6.conf.docker0.disable_ipv6 = 1
net.ipv6.conf.eth0.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.eth2.stable_secret"
sysctl: reading key "net.ipv6.conf.lo.stable_secret"
net.ipv6.conf.eth1.disable_ipv6 = 1
net.ipv6.conf.eth2.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.nat0.stable_secret"
sysctl: reading key "net.ipv6.conf.pnet0.stable_secret"
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.nat0.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.pnet1.stable_secret"
sysctl: reading key "net.ipv6.conf.pnet2.stable_secret"
net.ipv6.conf.pnet0.disable_ipv6 = 1
net.ipv6.conf.pnet1.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.pnet3.stable_secret"
sysctl: reading key "net.ipv6.conf.pnet4.stable_secret"
net.ipv6.conf.pnet2.disable_ipv6 = 1
net.ipv6.conf.pnet3.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.pnet5.stable_secret"
sysctl: reading key "net.ipv6.conf.pnet6.stable_secret"
net.ipv6.conf.pnet4.disable_ipv6 = 1
net.ipv6.conf.pnet5.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.pnet7.stable_secret"
sysctl: reading key "net.ipv6.conf.pnet8.stable_secret"
net.ipv6.conf.pnet6.disable_ipv6 = 1
net.ipv6.conf.pnet7.disable_ipv6 = 1
sysctl: reading key "net.ipv6.conf.pnet9.stable_secret"
net.ipv6.conf.pnet8.disable_ipv6 = 1
net.ipv6.conf.pnet9.disable_ipv6 = 1
I have to manually re-enabled IPv6 on every reboot

Code: Select all

root@eve:~# sysctl -p /etc/sysctl.conf 
net.ipv6.conf.pnet0.disable_ipv6 = 0
root@eve:~# systemctl restart networking
root@eve:~# 
What keeps disabling IPv6 and why? at least it should not disable pnet0 ipv6, it's almost 2020 disabling v6 isn't a good practice
I'm getting the same problem

Post Reply