Bare-Metal install - LACP Attachement

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Post Reply
Tangi
Posts: 2
Joined: Wed Feb 26, 2020 11:24 am

Bare-Metal install - LACP Attachement

Post by Tangi » Wed Feb 26, 2020 12:55 pm

Hello,

I have just installed the community edition over a fresh ubuntu 16.04 LTS install.
I want to double attach my eve-ng server to a physical cisco switch with LACP.
In the future, the eve-ng server would be installed on a vPC ( of 2 nexus ), with LACP.
I need to be able to patch my physical cisco switches without loosing connectivity to my eve-ng server.

I never managed to get LACP packets between my bond0 interface ( eth0 and eth1 bridged ) and my cisco switch.


My cisco setup :

Code: Select all

#show running-config interface gigabitEthernet 0/5
Building configuration...

Current configuration : 116 bytes
!
interface GigabitEthernet0/5
 switchport access vlan 10
 switchport mode access
 channel-group 1 mode active
end

#show running-config interface gigabitEthernet 0/6
Building configuration...

Current configuration : 116 bytes
!
interface GigabitEthernet0/6
 switchport access vlan 10
 switchport mode access
 channel-group 1 mode active
end


#show running-config interface port-channel 1
Building configuration...

Current configuration : 82 bytes
!
interface Port-channel1
 switchport access vlan 10
 switchport mode access
end
my ubuntu setup :
# cat /etc/network/interfaces

Code: Select all

# The primary network interface
allow hotplug eth0
iface eth0 inet manual
    bond-master bond0

allow hotplug eth1
iface eth1 inet manual
    bond-master bond0

auto bond0
iface bond0 inet manual
    bond-mode 4 
    bond-miimon 100
    bond-lacp-rate 1
    bond-slaves none

auto pnet0
iface pnet0 inet static
    address 10.156.232.74
    netmask 255.255.248.0
    gateway 10.156.239.254
    dns-domain labs.arkea.com
    dns-nameservers 10.154.30.4 10.154.99.65
    bridge_ports bond0
    bridge_stp off


Feb 26 10:59:27.024: %LINK-3-UPDOWN: Interface GigabitEthernet0/5, changed state to down
Feb 26 10:59:27.146: %LINK-3-UPDOWN: Interface GigabitEthernet0/6, changed state to down
Feb 26 11:46:39.322: %LINK-3-UPDOWN: Interface GigabitEthernet0/5, changed state to up
Feb 26 11:46:39.525: %LINK-3-UPDOWN: Interface GigabitEthernet0/6, changed state to up
Feb 26 11:46:45.362: %EC-5-L3DONTBNDL2: Gi0/5 suspended: LACP currently not enabled on the remote port.
Feb 26 11:46:46.068: %EC-5-L3DONTBNDL2: Gi0/6 suspended: LACP currently not enabled on the remote port.
Feb 26 11:47:01.206: %LINK-3-UPDOWN: Interface GigabitEthernet0/5, changed state to down
Feb 26 11:47:01.206: %LINK-3-UPDOWN: Interface GigabitEthernet0/6, changed state to down
Feb 26 11:47:04.247: %LINK-3-UPDOWN: Interface GigabitEthernet0/5, changed state to up
Feb 26 11:47:04.250: %LINK-3-UPDOWN: Interface GigabitEthernet0/6, changed state to up
Feb 26 11:47:10.863: %EC-5-L3DONTBNDL2: Gi0/6 suspended: LACP currently not enabled on the remote port.
Feb 26 11:47:11.125: %EC-5-L3DONTBNDL2: Gi0/5 suspended: LACP currently not enabled on the remote port.
Feb 26 11:47:13.645: %LINK-3-UPDOWN: Interface GigabitEthernet0/5, changed state to down
Feb 26 11:47:13.649: %LINK-3-UPDOWN: Interface GigabitEthernet0/6, changed state to down
Feb 26 11:47:16.648: %LINK-3-UPDOWN: Interface GigabitEthernet0/5, changed state to up
Feb 26 11:47:16.651: %LINK-3-UPDOWN: Interface GigabitEthernet0/6, changed state to up
Feb 26 11:47:22.443: %EC-5-L3DONTBNDL2: Gi0/6 suspended: LACP currently not enabled on the remote port.
Feb 26 11:47:22.460: %EC-5-L3DONTBNDL2: Gi0/5 suspended: LACP currently not enabled on the remote port.

i have tried a setup from this page :
http://www.thingnetwork.io/working-with ... and-wlan0/

Still the same issue.

Any advice ?

Uldis (UD)
Posts: 2943
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Bare-Metal install - LACP Attachement

Post by Uldis (UD) » Wed Feb 26, 2020 2:10 pm

Bad choice dear....
Single NIC is ok...
dual is not tested and 99% it is not ok at all

wepesein
Posts: 1
Joined: Tue Mar 03, 2020 2:39 pm

Re: Bare-Metal install - LACP Attachement

Post by wepesein » Tue Mar 03, 2020 2:41 pm

I have also faced the same issue. Finally be able to resolve the issue TWC Email .

Thanks
Last edited by wepesein on Wed Mar 04, 2020 4:17 pm, edited 1 time in total.

Tangi
Posts: 2
Joined: Wed Feb 26, 2020 11:24 am

Re: Bare-Metal install - LACP Attachement

Post by Tangi » Tue Mar 03, 2020 5:53 pm

What have you done ?

Post Reply