Link to wireshark failing

Moderator: mike

Post Reply
adgwytc
Posts: 3
Joined: Tue Jan 14, 2020 1:32 pm

Link to wireshark failing

Post by adgwytc » Tue Jan 14, 2020 1:35 pm

Hi,

When in the lab, right click on the Node, click on capture then the port. Wireshark launches which is great but then I get the following error:

"End of file on Pipe Magic during open"

Anyone else seen this please and how they fixed the issue?

hugolin
Posts: 5
Joined: Thu Oct 05, 2017 8:00 am

Re: Link to wireshark failing

Post by hugolin » Wed Jan 15, 2020 9:51 pm

Yes, I just came back to eve-ng, which I used heavilly before and used the capture regularly, now with fresh install of host os I did not have the client pack,
installed it and first there was this shitty trouble with npcap.
By default it said only for administrators during the install and then when I opened up the wireshark it gave me pop up about privileges for like 10 times.
And then...yes, the same situation as you, I installed the client pack, now running a switch, I click on the box, interface, wrapper starts the wireshark
and in a little while I get the same message as you - End of file on pipe magic during open.
Would desperately need to see some packets of MSTP...grrrrrr. Hopefully someone can shed some light.

sounknownyet
Posts: 18
Joined: Tue Mar 05, 2019 4:42 pm

Re: Link to wireshark failing

Post by sounknownyet » Wed Jan 29, 2020 11:30 am

If you follow this you should never have a problem with Wireshark:

Uninstall Wireshark if you have any.
Install EVE-NG tools.
Go to C:\Program Files\EVE-NG and find the file - wireshark_wrapper. Open it with notepad and make sure you have correct username and password. Save it.
Run EVE-NG lab and try to capture traffic. It should work.

Uldis (UD)
Posts: 3362
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Link to wireshark failing

Post by Uldis (UD) » Wed Jan 29, 2020 12:02 pm

before you start use wireshark, do first time ssh to your eve using Putty!
it will ask save a SSH key do it
then make sure your wireshark is installed in path matching wireshark_wrapper

done

tandonsu
Posts: 1
Joined: Sat Feb 22, 2020 8:12 am

Re: Link to wireshark failing

Post by tandonsu » Sat Feb 22, 2020 8:24 am

hi Uldis (UD),

that worked! many thanks :)

Post Reply