Page 1 of 1

[Req] How-To Add - vExtremeOS ?

Posted: Mon Nov 20, 2017 3:16 pm
by petrovg

I am facing some issues running ExtremeOS in EVE and I am wondering what is the correct procedure to add the image.
In supported images we have ExtremeOS 21.1.14 but the 'howto-s' page does not show an example so I thought it is easy....


we have
- EXOS ISO Files
- .xos Files
- .qcow2 files for GNS3

I've tried using the files for GNS3 and I am placing them under /opt/unetlab/addons/qemu/extremexos-X
for example:
root@eve-ng:/opt/unetlab/addons/qemu/extremexos- pwd
root@eve-ng:/opt/unetlab/addons/qemu/extremexos- ls

Do I need to do any conversion of the file or use .xos/.iso instead?
I am fixing the permissions with /opt/unetlab/wrappers/unl_wrapper -a fixpermissions
after the file is placed in the correct directory with the hda filename.

Thanks in advance!

Re: [Req] How-To Add - vExtremeOS ?

Posted: Mon Nov 20, 2017 3:55 pm
by mcleish
Does the image boot? I believe you can only connect to it with VNC.

Re: [Req] How-To Add - vExtremeOS ?

Posted: Mon Nov 20, 2017 7:19 pm
by petrovg
At first it shows as it is starting and I get a log that the node is started (in Notifications) but few seconds later the node is back greyed out.

I remember last week when I tried it the node was starting but opening a console was just blank - nothing was happening.

So I assume I am doing something wrong. Could anyone give it a try, please:
Here are the images -