apt upgrade error to v2.0.3-110 . Cannot login to eve web

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Locked
kbmelati
Posts: 11
Joined: Fri Mar 24, 2017 2:54 am

apt upgrade error to v2.0.3-110 . Cannot login to eve web

Post by kbmelati » Thu Apr 09, 2020 4:36 pm

Hi,

i just apt update and apt upgrade, but stuck when upgrade package "eve-ng".

Log:

apt update
apt upgrade
...
(Reading database ... 163493 files and directories currently installed.)
Preparing to unpack .../eve-ng_2.0.3-110_amd64.deb ...
Checking MySQL... failed
dpkg: error processing archive /var/cache/apt/archives/eve-ng_2.0.3-110_amd64.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/eve-ng_2.0.3-110_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@eve-ng:~#

problem is "Checking MySQL... failed". Now i cannot login to eve-ng html, but can login via SSH.

please help.

thanks.

Uldis (UD)
Posts: 3106
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: apt upgrade error to v2.0.3-110 . Cannot login to eve web

Post by Uldis (UD) » Thu Apr 09, 2020 9:10 pm

Nice you had killed your sql database

it is full eve reinstall now

visit our live chat to tal with eve experts
https://www.eve-ng.net/index.php/live-helpdesk/
use gmail to join

kbmelati
Posts: 11
Joined: Fri Mar 24, 2017 2:54 am

Re: apt upgrade error to v2.0.3-110 . Cannot login to eve web

Post by kbmelati » Fri Apr 10, 2020 2:43 am

Uldis (UD) wrote:
Thu Apr 09, 2020 9:10 pm
Nice you had killed your sql database

it is full eve reinstall now

visit our live chat to tal with eve experts
https://www.eve-ng.net/index.php/live-helpdesk/
use gmail to join
thanks Uldis.

I try to remove eve-ng and reinstall again.

when intall eve-ng again, it failed at mysql-server. error:
===
root@eve-ng:~# apt install mysql-server-5.7
Reading package lists... Done
Building dependency tree
Reading state information... Done
mysql-server-5.7 is already the newest version (5.7.29-0ubuntu0.16.04.1).
...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up mysql-server-5.7 (5.7.29-0ubuntu0.16.04.1) ...
mysql_upgrade: Got error: 1045: Access denied for user 'debian-sys-maint'@'localhost' (using password: YES) while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: error processing package mysql-server-5.7 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.7; however:
Package mysql-server-5.7 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
mysql-server-5.7
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@eve-ng:~#
===

it said: mysql_upgrade: Got error: 1045: Access denied for user 'debian-sys-maint'@'localhost' (using password: YES) while connecting to the MySQL server

thanks.

Uldis (UD)
Posts: 3106
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: apt upgrade error to v2.0.3-110 . Cannot login to eve web

Post by Uldis (UD) » Fri Apr 10, 2020 7:15 am

come in EVE Live chat

eliotradisa
Posts: 2
Joined: Fri Apr 17, 2020 9:05 pm

Re: apt upgrade error to v2.0.3-110 . Cannot login to eve web

Post by eliotradisa » Fri Apr 17, 2020 9:07 pm

Uldis (UD) wrote:
Fri Apr 10, 2020 7:15 am
come in EVE Live chat
mysql_upgrade: Got error: 1045: Access denied for user 'debian-sys-maint' Tutuapp 9Apps ShowBox @'localhost' (using password: YES) while connecting to the MySQL server

smithclarkson02
Posts: 1
Joined: Tue Apr 21, 2020 5:10 pm

Re: apt upgrade error to v2.0.3-110 . Cannot login to eve web

Post by smithclarkson02 » Tue Apr 21, 2020 5:12 pm

If I was getting this message I'd run

apt remove xe-guest-utilities
apt install xen-tools
If I was being really thorough I'd investigate why those packages are conflicting, I suspect the maintainer might have moved stuff around.

nirvanausual
Posts: 1
Joined: Sat May 23, 2020 9:55 pm

Re: apt upgrade error to v2.0.3-110 . Cannot login to eve web

Post by nirvanausual » Sat May 23, 2020 9:57 pm

You can comment the unresolved repo from the file sources.list found on dir /etc/apt/

After modifying the sources.list, clean the apt-get repo as

Code: Select all

apt-get clean
Then update

Code: Select all

apt-get update
The error will gone away

Locked