Custom template interface naming is not working

Before posting something, READ the changelog, WATCH the videos, howto and provide following:
Your install is: Bare metal, ESXi, what CPU model, RAM, HD, what EVE version you have, output of the uname -a and any other info that might help us faster.

Moderator: mike

Locked
sajiby3k
Posts: 11
Joined: Mon Sep 25, 2017 2:19 pm

Custom template interface naming is not working

Post by sajiby3k » Tue Sep 10, 2019 10:03 pm

Hi,

I have created a custom template below to add a new node type in eve-ng -

type: qemu
name: Clavister-cOS
cpulimit: 1
icon: Firewall.png
cpu: 1
ram: 512
ethernet: 4
eth_name:
- If1/Mgmt
eth_format: If{2}
console: telnet
qemu_arch: x86_64
qemu_nic: virtio-net-pci
qemu_options: -machine type=pc-1.0,accel=kvm -serial mon:stdio -nographic -nodefconfig
-nodefaults -display none -vga std -rtc base=utc

I will rename first interface as "If1/mgmt" which works fine. Then next interfaces will begin number from If2, If3, If4 so on.
But other interface names always starts from If0. It looks like whatever your do, the interface numbering always starts from zero (0).

Can anyone help me what I am doing wrong? Or is it a bug?
You do not have the required permissions to view the files attached to this post.

sajiby3k
Posts: 11
Joined: Mon Sep 25, 2017 2:19 pm

Re: Custom template interface naming is not working

Post by sajiby3k » Tue Sep 10, 2019 10:35 pm

I am also interested, how the developers hide their custom naming in built in yml files.

For example -

type: qemu
name: Fortinet
cpulimit: 1
icon: Firewall.png
cpu: 1
ram: 1024
ethernet: 4
console: telnet
qemu_arch: x86_64
qemu_nic: virtio-net-pci
qemu_options: -machine type=pc-1.0,accel=kvm -serial mon:stdio -nographic -nodefconfig
-nodefaults -display none -vga std -rtc base=utc

The names starts from port1, then continues like port2, port3 etc. But built-in yml template has no definitions for it.

Anyone???

Uldis (UD)
Posts: 2505
Joined: Wed Mar 15, 2017 4:44 pm
Location: London
Contact:

Re: Custom template interface naming is not working

Post by Uldis (UD) » Wed Sep 11, 2019 5:36 am

I had answered it many times.
It is all described in EVE Cookbook section 17.3
https://www.eve-ng.net/images/EVE-COOK-BOOK-1.13.pdf

Starting from version 2.0.3-95 Community EVE supports same way how to make own templates as it is in the EVE Pro.

Uldis

Locked